Such a useful add-on Rated 5 out of 5 stars

I confirm "Stubi"'s suggestion:
FF20 broke it -- to fix, go to the developer's site and download the latest version.

This review is for a previous version of the add-on (0.14.2012122901.1-signed).