Rated 5 out of 5 stars

Please, update it so that it can work with Firefox 4.0!