No chance to use under FF 4.0 anymore? :-( Rated 5 out of 5 stars

I am also TOTALLY in love with this addon but it seems not to work anymore under FF 4, so far I could make it work all these years under FF 3.0, 3.5 and these days 3.6 but under FF 4 all these tricks are not working anymore right now.
Really too bad that the developer lost interest in this great addon and no one else developed something similar so far:-(
If anyone finds a way to make this work under FF 4 please share how to do it or I have to stay on FF 3.6 forever...

This user has a previous review of this add-on.