Version 3.5 Rated 2 out of 5 stars

Where do I get a version that works with FF 3.5 as all the links mentioned are for version 3.0

This review is for a previous version of the add-on (1.52).