Still doesn't work with Firefox 20 Rated 1 out of 5 stars

Just tested, and it's still doesn't work with Firefox 20, and after downgrading to Firefox 19.0.2 too. :'(
---------------------------------------
Ubuntu 12.04.2 LTS amd64

This user has a previous review of this add-on.