Foxkeh Rated 5 out of 5 stars

We need a version that is compatible with Firefox 3.6 ASAP!