Love the extension Rated 5 out of 5 stars

Love the extension. Nice and simple.

FFx 3, though, the developer says he has issues:

"April 8, 2008 - 20:20 PDT

Extension updates for Firefox 3.0 are on the horizon. I'm going to have to change the GUIDs, though, to be compatible with the FUEL preference support, so I'm going to have to figure out how to make it easy for users to get the new versions. I'm also in serious crunch time at work, so please forgive the dust..."

Changing the MaxVersion worked just fine for me. I think it might be more of an issue with version releases. I know I've tried to make edits to the extension version of other extensions, and FFx spits them out as being incompatible ...

EDIT:
The only other link to a modified xpi that installs on 3 is unreliable (too many users from your ip error), and makes you wait. I made my own:
http://write-me.org/downloads/xpi/titlebar_tweaks.xpi