Tiny JavaScript Debugger Version History

10 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 1.1.5 40.3 KiB Works with Firefox 24.0 and later, SeaMonkey 2.21 and later, Thunderbird 24.0 and later

Resolved compatibility issues with Firefox 45.

Version 1.1.4 40.2 KiB Works with Firefox 24.0 and later, SeaMonkey 2.21 and later, Thunderbird 24.0 and later

Fixed compatibility issues with Firefox 42 and 43.

Version 1.1.3 39.9 KiB Works with Firefox 24.0 and later, SeaMonkey 2.21 and later, Thunderbird 24.0 and later

Fixed bug with displaying source code on Firefox 42+.

Version 1.1.2 39.4 KiB Works with Firefox 24.0 and later, SeaMonkey 2.21 and later, Thunderbird 24.0 and later

Fixed bug with not always stopping at breakpoint

Version 1.1.1-signed 39.2 KiB Works with Firefox 24.0 and later, SeaMonkey 2.21 and later, Thunderbird 24.0 and later

Added support for "debugger" statement in source code. Fixed a bug that prevented the debugger from stopping when reopening a dialog with breakpoints.

Version 1.0.1.1-signed 38.8 KiB Works with Firefox 24.0 and later, SeaMonkey 2.21 and later, Thunderbird 24.0 and later

Fixed compatibility issue with Firefox 34.

Version 1.0.1-signed 41.8 KiB Works with Firefox 24.0 and later, SeaMonkey 2.21 and later, Thunderbird 24.0 and later

Browsing of objects and arrays has been added; added menu entry for Komodo.

Version 0.9.8.1.1-signed 37.4 KiB Works with Firefox 24.0 and later, SeaMonkey 2.17 and later, Thunderbird 24.0 and later

Fixed broken displaying of watchlist items while debugging

Version 0.9.8.1-signed 37.4 KiB Works with Firefox 17.0 and later, SeaMonkey 2.14 and later, Thunderbird 17.0 and later

- Changed implementation to support new debugger API.
- Improved behavior of Step In and Step Over functions
- Added browsing properties of watched variables

Version 0.9.5.1-signed 32.6 KiB Works with Firefox 17.0 and later, SeaMonkey 2.14 and later, Thunderbird 17.0 and later

  • Fixed compatibility issues to Firefox/Thunderbird 24 and newer
  • Added conditional breakpoints