Rated 4 out of 5 stars

This addon supports FF5, You just have to edit install.rdf file inside (you can open xpi with winrar) to this:
<em:minVersion>1.5</em:minVersion>
<em:maxVersion>5.0.*</em:maxVersion>
Please fix this issue.