Rated 4 out of 5 stars

Make This Compatible
Tell Firefox to stop checking the compatibility of all your add-ons. After you do this all your incompatible extensions Should automatically work. Note: On some you MAY notice they are not working exactly the same. Most will though.
***************************************************************************************
Follow this Simple procedure:

Type "about:config" in the address bar: (without the " ")
> Right-click on any empty area to see the context menu (right click)
> Select "New"
> Select "Boolean"
> Type or copy/paste "extensions.checkCompatibility.9.0.1" (without the " ") Note: Make sure there is a dot Before the first number

> Set the value to "false"

After doing the above, you can add this extension to Firefox without seeing the "....could not be installed...." message

FYI: Any Custom changes you or your extensions make will be in bold in about:config

More officially about this from Mozilla: http://kb.mozillazine.org/Extensions.checkCompatibility