Works with v3.5 Rated 4 out of 5 stars

This version works (for me) with 3.5 if with the maxVersion in the install.rdf (inside the .xpi file) changed.

This review is for a previous version of the add-on (0.1.8).  This user has other reviews of this add-on.