Problem with alfa17 Rated 5 out of 5 stars

The last alfa 17 does not work on Firefox 22-23 under Windows XP. I reverted back to alfa7 from my backups. It works perfectly.

This review is for a previous version of the add-on (1.0alpha17).