Nice idea, but... Rated 2 out of 5 stars

Mozzila add-ons page says it's compatible up to TB version 17, but the add-on homepage itself says it's only compatible up to TB version 9, and hasn't been updated since December 2011. I'm on TB17 and I can't get this add-on to work.

This review is for a previous version of the add-on (2.1.702).