Firefox 4.0 support Rated 4 out of 5 stars

Doesn't work with Firefox 4.0. Will try to live with chrome for now.

This review is for a previous version of the add-on (1.4).