Rated 5 out of 5 stars

Why is <em:maxVersion>8.*</em:maxVersion> @@?

This review is for a previous version of the add-on (1.0.1). 

Support for TB major versions.

Done! :) It should be available soon until it passes Mozilla's review process.