Rated 1 out of 5 stars

The addon could not be installed because it does not match the add-on Firefox expected.

This review is for a previous version of the add-on (1.1). 

Try again?

Could you try installing it again, if you still use Tamper Data? I've fixed the issue with installation.