firefox 4 Rated 5 out of 5 stars

I thought tagsieve was incompatible with firefox 4, but tagsieve 4.3.0 does work in firefox 4 and tagsieve 4.3.0 is at http://dev.grue.in/issues/51

This review is for a previous version of the add-on (4.2.8).