Rated 4 out of 5 stars

I spoke too soon - It turns out that in FF4.0b7, this extension makes closed tabs fail to visually disappear, and continue as phantom tabs, even thought they are actually closed.

So, this is not compatible with FF4.0b7

Not compatible with FF4.0b7 Rated 4 out of 5 stars

spoke too soon - It turns out that in FF4.0b7, this extension makes closed tabs fail to visually disappear, and continue as phantom tabs, even thought they are actually closed.

So, this is not compatible with FF4.0b7