It does work with 3.1b2 (and 3.5b4) Rated 5 out of 5 stars

Just rename the .xpi file to have a .zip extension, open the archive, then go into the .rdf file and update the version to “3.*.*”.

At least, that's what I did, and no smoke here...

This review is for a previous version of the add-on (0.3.3).