Missing Sought-For Feature Rated 3 out of 5 stars

Nice but what I really want is to force javascript popups to open in a new tab. Haven't seen anyone design that yet. The LA Times website pops up the registration for their site and it's *very* annoying. I only put up with it because I live in the LA area. (Yes, I complained. They think it's a "feature".)

wonderful until FF3.6.xx Rated 5 out of 5 stars

Works wonderfully in FF3.6.xx on my other PC.Now I tried FF11 on a new computer and TOR(M) puts every new tab at the end of the tab bar, no matter where they come from.Anyway 4**** for the idea and the great performance until FF3.6.xx :-) ------ EDIT: it finally works up from FF 9.0.1 to FF 12.0 !! THANKS MUCH for modifying.

Used to use this, but... Rated 4 out of 5 stars

I used to use this, and it certainly does what it says it does. However, the Tabs Mix Plus add-on contains this functionality and many more options—so you may want to check that too, depending on what you need.

Rated 1 out of 5 stars

Version 1.2 NOT WORKED under FireFox 3.6.23. Bookmarks always opened at the end of the tabbar.

This user has a previous review of this add-on.

It works perfectly in every version up to the latest (8 at the time of writing) as long as you set your preferences and about:config flags correctly. Also make sure you don't have other extensions that could conflict.

As an experiment make a new profile, install just this extension and set it up as I describe in the description. It will work as advertised. Then you can figure out what you did to break it on your main profile.

Or how about this: stop moaning and fix it yourself. The source code is available. That is what I did when I created Tabs Open Relative (modified) - I fixed Tabs Open Relative instead of just complaining about it.

Rated 5 out of 5 stars

Thank you for ability to open links from external programs in a new window (vs arbitrarily to the last-used window, which may be one which I want to keep open only for a certain task!)

Rated 5 out of 5 stars

Wow, it works with FF6!
Great job mate, nice add-on for me 'cause the former Open Tab Relative didn't work with recent FF's versions.

Thanks!

Rated 4 out of 5 stars

Working right in FF 11.0a1 (Nightly), But it should be modified in order to create the needed options in about:config to make it work without further user intervention (as description indicates), it's quite absurd not to create them automatically, isn't it?

Still needed in Firefox 5... Rated 5 out of 5 stars

Good stuff.
I still can't believe you need this in Firefox 5...
Thanks for keeping this updated!

This user has 2 previous reviews of this add-on.

Rated 5 out of 5 stars

Works exactly as intended for me. I am using Firefox 3.6.3, with the following two preferences set in about:config as recommended:

browser.link.open_newwindow = 1
browser.link.open_external = 3

-- All links *normally* (exept pop-up windows) open in the same tab.
-- If I do Ctrl-click the link opens in a new tab. (It then opens to the right of the current tab -- but isn't that the default behavior nowadays anyway? I'm not sure that this extension is needed to achieve that anymore.)
-- If I click a link in my email-program ("external links"), the link opens in a *new* tab (to the far right).

Perfect! Without the extension, the "external links" open in the currently open tab. That is not good at all. What if I am currently filling in a form in that tab? I may lose that data then. This extensions solves this problem.

Regarding the recommended preferences in about:config -- I am not sure what the "extensions.tabsopenrelative.linksonly" setting does -- it doesn't seem to alter any behavior? Or does it?

This review is for a previous version of the add-on (1.1). 

Rated 1 out of 5 stars

It doesn't work at all :(

This review is for a previous version of the add-on (1.1). 

Do you understand what it does and how it works? Did you set the preferences correctly?

Rated 1 out of 5 stars

It seems addon just don't work!?
FF 3.6.10

This review is for a previous version of the add-on (1.1). 

Rated 1 out of 5 stars

Doesn't work anything like the original. When I click gmail manager it opens at the end. When I click for a new tab it's at the end. And links inside gmail don't work at all.

This review is for a previous version of the add-on (1.1). 

Rated 1 out of 5 stars

This add-on disables the Google Search setting that opens links in a new tab.

This review is for a previous version of the add-on (1.1). 

Rated 1 out of 5 stars

Uninstalled this, since it doesn't work, and Installed Tabberwokky.

This review is for a previous version of the add-on (1.1). 

Rated 1 out of 5 stars

The decision to open new tabs at the far right is brain dead for an extension called "Open Tabs Relative". What happened to the original behaviour? !@#$!

This review is for a previous version of the add-on (1.1). 

When!!! Rated 1 out of 5 stars

Prior to version 3.6 everything worked fine, but after all not working, when corrected, bothers to open the tab at the end?!!!

This review is for a previous version of the add-on (1.1). 

Rated 1 out of 5 stars

I also used this so all tabs (in a link, or ctrl-t) would open directly to the right of the current tab im in, can we get this feature back?

This review is for a previous version of the add-on (1.1). 

Rated 4 out of 5 stars

Version 1.1 on Firefox 3.6.3 seems to make Google Apps Mail links in emails not work, they just timeout.

Good Add-On though I love having tabs open relative thanks! Just fix that bug if you can!

This review is for a previous version of the add-on (1.1). 

Rated 1 out of 5 stars

This did not work for me at all in Firefox 3.6, so I installed Tab Utilities instead and got the same functionality.

This review is for a previous version of the add-on (1.1). 

useless Rated 1 out of 5 stars

"I wish new tabls (ctrl+"t") would also open to the right of the current one. I realize that's not necessarily the purpose of this add-on, but the pre-3.6 version did so and it was useful.
"
used just for this, without it plugin is useless

This review is for a previous version of the add-on (1.1).