Rated 3 out of 5 stars

You really need to update your extension if possible. Not only for the 8.0 nightlies, but because the Aurora 7.0 release is about to go into Beta on August 16h. It would be nice to have a new release that is compatible with it, if not all the way up to the 8.0 alpha release and beyond. I hope you see this and release a newer one soon. You must update it as soon as possible, because Firefox 5 and even the soon to be released version 6 are obsolete. After using version 7 or higher nobody wants to go back to the older ones. Not only are they faster, but there is a HUGE difference in terms of memory usage and responsiveness. What used to use 500mb or more, now only uses up 300mb or less. You can have many tabs open, leave your browser running overnight or for days, and it still only take up 300mb or so. You will notice no slowdown or lock-ups at all. It is truly amazing what they have done to Firefox 7.0 and beyond. I hope your extension updates soon to get with the times. Thanks for your hard work on a pretty cool and useful extension!!

This user has other reviews of this add-on.