Firefox 4 Support? Rated 3 out of 5 stars

It doesn't appear to work with Firefox 4 yet.... :(

This user has a previous review of this add-on.

It is supposed to work with Firefox 4. Please report your exact issue.