Rated 2 out of 5 stars

Newest version doesn't work properly :(And i cant instal version 0.5 ,it says not compatible with firefox 6.0.2

This review is for a previous version of the add-on ( 

You can install older version, just install https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/ then restart your firefox, after that you'll be able to install incompatible addons to your firefox. Otherwise if you want me to fix the problem you should explain more about the problem you have.