Rated 4 out of 5 stars

A good workaround for this extension and many other outdated ones that *actually do* work with a newer Firefox release is to install the MR Tech Toolkit addon. It has a feature to override 'maxVersion' compatibility checking. You can get it here: https://addons.mozilla.org/en-US/firefox/addon/421