Update required! Rated 5 out of 5 stars

Please update, it doesn't work for the beta version.

This review is for a previous version of the add-on (1.5.1).