Mozilla should require this add-on Rated 5 out of 5 stars

Like prysmcat I find this add-on a requirement to going to a new version of Firefox. (In fact, if by mistake I upgrade while Tab Utilities doesn't work, I'll uninstall and downgrade til it does work.) IMHO, Mozilla should either A) Include this add-on as part of Firefox (and provide the author an appropriate donation) or B) insure Tab Utilities (and other important add-ons) are working before pushing a new upgrade out to everyone. I know neither of these are reasonable given the current climate, but its the way it rolls, anyway, for many of us. This add-on is an essential part of using Firefox, period.

This review is for a previous version of the add-on (1.5).