Not compatible yet with FF 12 beta Rated 4 out of 5 stars

I miss it. Hope the Tab Utilities addon updates automatically when it is made compatible with new FF releases. I'll keep checking back.

This review is for a previous version of the add-on (1.1.3.1-signed).