Addon needs an update for FF3.5 Rated 5 out of 5 stars

This is a very useful addon. Could the author kindly update it to v3.5? Thanks.