Working Firefox 3.01 plugin version Rated 5 out of 5 stars

If you have upgraded to Firefox 3.01 and don't wont to the hustle with editing the install file to make this plugin work, get the pre-edited file as posted by magopaco earlier here:

http://tinyurl.com/6quxhr

Just "open" the file straight within Firefox and you're done. This worked perfectly for me (after failing at trying to modify the file myself)

This review is for a previous version of the add-on (0.3.6).