Not compatible with FF 17.0. Rated 5 out of 5 stars

I am *extremely* disappointed that this extension no longer works in Firefox. Without it, Firefox is no better than IE or Chrome. Seriously. This extension "made" the browser. FF programmers should incorporate the thing *in its entirety* into FF (allowing that the extension author agrees to this, of course.)

This review is for a previous version of the add-on (0.4.0.3).