Rated 1 out of 5 stars

Not compatible with Firefox 17

Why is it even "featured" if it's not compatible?

It was working well before Firefox just updated itself, now how can I revert back to Firefox 16? Because I cannot work without this extension!

Firefox should really notify about incompatibles extensions BEFORE UPDATING!!! this is so stupid...

This review is for a previous version of the add-on (0.4.0.3).