Please Update for FF 3.0 Rated 5 out of 5 stars

Very good extension, Incompatibility to FF 3.0 is
preventing me from using FF 3.0

This review is for a previous version of the add-on (0.3.6).