Now works with FF 3.5! Rated 5 out of 5 stars

Now works with FF 3.5:

Tab Mix Plus Dev-Build 0.3.7.4pre.090516

http://tmp.garyr.net/forum/index.php

This review is for a previous version of the add-on (0.3.7.3).