Rated 4 out of 5 stars

Bug 18808 says this works with FF 3.6, but the addons page refuses to install it. Please change the version limit in the add-on to allow the installation.