Rated 5 out of 5 stars

Beta 1.0.7 of this works in FF 3.6 so use that?