PLEASE UPDATE THIS !!! Rated 5 out of 5 stars

It may have worked for 3.5.2, but it sure as hell doesn't work for Firefox 3.5.2.