Rated 1 out of 5 stars

It is not compatible with FF 3.5.2 I added it based upon tteyob assurance that it worked, It does not. I tried to go into options and i am unable to, I had overridden the max compatibility setting and nothing is happening. I used this add-on in the past and it is actually kind cool. But if you are a FF 3.5.2 user it will probably not work. Too bad, I liked it, it really is about a 3.5 star add-on but is just for effect, no practical application at all in my mind. At this point in time I rate it a 1, the developer does not even bother with it anymore.