Tab Cycler Version History

3 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 3.1-signed.1-signed 20.9 kB Works with Firefox 4.0b4 and later

Adding compatibility with newer Firefox versions ("splitmenu" element was removed).

Version 2.1-signed.1-signed 20.5 kB Works with Firefox 4.0b4 and later

  • Supports custom intervals
  • Deletes saved preferences if uninstalled

Version 1.1-signed.1-signed 31.8 kB Works with Firefox 4.0b4 and later