Rated 1 out of 5 stars

This extension is definitely NOT COMPATIBLE with 3.7a1 and trying to access its OPTIONS renders the Add-Ons window unclickable AND unclosable.

Besides that, this extension here=> https://addons.mozilla.org/en-US/firefox/addon/6391 is TONS BETTER! (and everything works in 3.7a1 too!)

This review is for a previous version of the add-on (1.8.2). 

It works fine with 3.7a1

I've tested the extension with 3.7a1 and it works fine. The extension you linked to breaks my extension when it's installed (it overwrites my extension's chrome overlay) so that's most likely why you are having problems.