FF 3.6 Incompatible Rated 2 out of 5 stars

Version 0.5.2 is not compatible with FF 3.6 as it shows in the description above. You will have trouble with tabs opening when using the search bar and bookmarks. FF 3.6 unfortunately is not flagging this addon as incompatible.

This review is for a previous version of the add-on (0.5.2).