Switchy Version History

14 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 0.9.4 1.6 MB Works with Firefox 26.0 and later

Polish locale added and a fix in the confirm dialog when switching profiles.

Version 0.9.3 1.6 MB Works with Firefox 26.0 and later

This version supports the latest mac firefox versions.

Version 0.9.2 1.6 MB Works with Firefox 26.0 and later

This version fixes some small UI issues.

Version 0.9.1 1.6 MB Works with Firefox 26.0 and later

This version fixes a UI issue about selecting a profile from an empty select in the switchy panel.

Version 0.9.0 1.6 MB Works with Firefox 26.0 and later

Switchy 0.9.0 has a new UI panel and uses the latest addon-sdk framework.

Version 0.8.2 155.4 kB Works with Firefox 4.0b1 and later

The previous version had a problem detecting the windows 8 path of Firefox.
This is fixed in the new version.

Version 0.8.1 155.3 kB Works with Firefox 4.0b1 and later

Compatibility with new firefox releases

Version 0.8 155.3 kB Works with Firefox 4.0b1 and later

This version has been optimized for debian users.

Version 0.7 155.4 kB Works with Firefox 4.0b1 and later

Windows support improved

Version 0.6 154.6 kB Works with Firefox 4.0b1 and later

Just an improvement for the linux users: the path of firefox is read from /proc/self/exe

Version 0.5 154.6 kB Works with Firefox 4.0b1 and later

Switchy 0.5 contains many improvements.
1. it is able to keep open more than one profile at the same time.
2. 'strange site opening behaviour' bug - fixed
3. profile detection bug - fixed
4. button in Navigation Bar configurable

Version 0.4 148.5 kB Works with Firefox 3.5 and later

This is a bug-fix release:
. the list of profile is sorted
. use of javascript modules
. small UI details

Version 0.3 147.5 kB Works with Firefox 3.5 and later

Renaming and deleting profiles, new UI, localisation and all known bugs fixed.

Version 0.1 136.2 kB Works with Firefox 3.5 and later