Please update to support firefox 16.01 Rated 5 out of 5 stars

It's not working in Firefox 16 or Firefox 16.0.1. Please update.

This review is for a previous version of the add-on (1.0.1). 

Thanks for the heads up. We'll look into it shortly.