Still going strong on FF 38 June 2015 Rated 5 out of 5 stars

I've been using this for years and it works in FF8. Just change to version number. Instructions here:
http://kb.mozillazine.org/Editing_an_add-on_to_change_its_compatibility