Firefox 3.5? Rated 5 out of 5 stars

I love this and I have used it since Fx 1.5 I think. But it's not compatible with Fx 3.5 :(