broken with FF 3.5.7 Rated 2 out of 5 stars

Have used this addon for several years. It break FFx 3.5.7 in several ways.
Some described below. Jeremy please fix your addon so it will run with 3.5.7