Rated 1 out of 5 stars

Please amend this mod so it does not install for people using firefox beyond 3.6.6 it simply breaks on install. Since very few people are using prior versions of 3.6.6 this addon needs to be marked not working.
It's one thing to install, its another not to be able to change any option, then the addon box just dies.