Compatibility Rated 2 out of 5 stars

Need compatibility with FF 3.5, please.