Rated 5 out of 5 stars

Quite good, but broken with FF 3.5, and it's been awhile since that came out. I think this has been abandoned.

This review is for a previous version of the add-on (1.1.2008042801).