Compatible with Firefox 5 Rated 4 out of 5 stars

This extension appears to work fine with Firefox 5.0, I'm not sure why it hasn't been updated to indicate it's compatible. I used Nightly Tester Tools to disable the extension compatibility check. Editing the install.rdf and manually overriding the version check also works. Please update the extension's version check, this is a handy extension.