Cannot use because FF 3.5.1 is buggy Rated 5 out of 5 stars

This is a great Add on. Unfortunately, FF 3.5.1 for Windows XP keeps crashing, so I reverted to FF 2.0.20 and now I can't find an older version of Spellbound to go with it. Can anyone help?

Thanks

This review is for a previous version of the add-on (3.0.6). 

3.*

I would suggest trying to find the installer for the last version just before 3.5. But I think FF 3.5.2 may be more stable, so try that first I guess.